const regex = /@([^\s.,;]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@([^\\s.,;]+)', 'gm')
const str = `asdfasdf @test1, asdf./,a fasdfasdf fasdfasdf
sertiosdf;gk gsdfgsdfijgioj 4gsdkg @username42;i`;
const subst = `<a href="$1">$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);