// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@([^\s.,;]+)").unwrap();
let string = "asdfasdf @test1, asdf./,a fasdfasdf fasdfasdf
sertiosdf;gk gsdfgsdfijgioj 4gsdkg @username42;i";
let substitution = "<a href=\"$1\">$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}