use strict;
my $str = 'asdfasdf @test1, asdf./,a fasdfasdf fasdfasdf
sertiosdf;gk gsdfgsdfijgioj 4gsdkg @username42;i';
my $regex = qr/@([^\s.,;]+)/mp;
my $subst = '<a href="$1">$1</a>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";