$re = '/@([^\s.,;]+)/m';
$str = 'asdfasdf @test1, asdf./,a fasdfasdf fasdfasdf
sertiosdf;gk gsdfgsdfijgioj 4gsdkg @username42;i';
$subst = "<a href=\"$1\">$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;