#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\w+)=(.*)"
Local $sString = "A=10" & @CRLF & _
"B=11"
Local $sSubst = ""$1":"$2","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)