import Foundation
let pattern = #"^(\w+)=(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A=10
B=11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$1":"$2","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)