#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)error(?:\[E\d+\])?: (?=.+\n +--> +([a-zA-Z0-9_\/.-]+):([\d]+):([\d]+))(.+)"
Local $sString = "ab/SourceFile.groovy: 19: errror_message @ line 19, column 5." & @CRLF & _
"" & @CRLF & _
"error: unterminated double quote string" & @CRLF & _
" --> src/main.rs:2:14" & @CRLF & _
" |" & @CRLF & _
"2 | println!("Hello, world!);" & @CRLF & _
" | ______________^" & @CRLF & _
"3 | | }" & @CRLF & _
" | |__^" & @CRLF & _
"" & @CRLF & _
"error: aborting due to previous error" & @CRLF & _
"" & @CRLF & _
"error: Could not compile `broken`." & @CRLF & _
"" & @CRLF & _
"error[E0072]: recursive type `blah::Blah` has infinite size" & @CRLF & _
" --> src/blah.rs:4:1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")