# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"error(?:\[E\d+\])?: (?=.+\n +--> +([a-zA-Z0-9_\/.-]+):([\d]+):([\d]+))(.+)"
test_str = ("ab/SourceFile.groovy: 19: errror_message @ line 19, column 5.\n\n"
"error: unterminated double quote string\n"
" --> src/main.rs:2:14\n"
" |\n"
"2 | println!(\"Hello, world!);\n"
" | ______________^\n"
"3 | | }\n"
" | |__^\n\n"
"error: aborting due to previous error\n\n"
"error: Could not compile `broken`.\n\n"
"error[E0072]: recursive type `blah::Blah` has infinite size\n"
" --> src/blah.rs:4:1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.