import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "error(?:\\[E\\d+\\])?: (?=.+\\n +--> +([a-zA-Z0-9_\\/.-]+):([\\d]+):([\\d]+))(.+)";
final String string = "ab/SourceFile.groovy: 19: errror_message @ line 19, column 5.\n\n"
+ "error: unterminated double quote string\n"
+ " --> src/main.rs:2:14\n"
+ " |\n"
+ "2 | println!(\"Hello, world!);\n"
+ " | ______________^\n"
+ "3 | | }\n"
+ " | |__^\n\n"
+ "error: aborting due to previous error\n\n"
+ "error: Could not compile `broken`.\n\n"
+ "error[E0072]: recursive type `blah::Blah` has infinite size\n"
+ " --> src/blah.rs:4:1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}