const regex = /error(?:\[E\d+\])?: (?=.+\n +--> +([a-zA-Z0-9_\/.-]+):([\d]+):([\d]+))(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('error(?:\\[E\\d+\\])?: (?=.+\\n +--> +([a-zA-Z0-9_\\\/.-]+):([\\d]+):([\\d]+))(.+)', 'gm')
const str = `ab/SourceFile.groovy: 19: errror_message @ line 19, column 5.
error: unterminated double quote string
--> src/main.rs:2:14
|
2 | println!("Hello, world!);
| ______________^
3 | | }
| |__^
error: aborting due to previous error
error: Could not compile \`broken\`.
error[E0072]: recursive type \`blah::Blah\` has infinite size
--> src/blah.rs:4:1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}