re = /error(?:\[E\d+\])?: (?=.+\n +--> +([a-zA-Z0-9_\/.-]+):([\d]+):([\d]+))(.+)/m
str = 'ab/SourceFile.groovy: 19: errror_message @ line 19, column 5.
error: unterminated double quote string
--> src/main.rs:2:14
|
2 | println!("Hello, world!);
| ______________^
3 | | }
| |__^
error: aborting due to previous error
error: Could not compile `broken`.
error[E0072]: recursive type `blah::Blah` has infinite size
--> src/blah.rs:4:1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end