package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bname=\"keyword\"\\r\\n\\r\\n([^-]+)\\r`)
var str = `b'----------------------------941135026682458398564529\r\nContent-Disposition: form-data; name="username"\r\n\r\nmyusername\r\n----------------------------941135026682458398564529\r\nContent-Disposition: form-data; name="password"\r\n\r\nmypassword\r\n----------------------------941135026682458398564529\r\nContent-Disposition: form-data; name="keyword"\r\n\r\nmykeyword\r\n----------------------------941135026682458398564529--\r\n'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}