$re = '/\bname=\"keyword\"\\\\r\\\\n\\\\r\\\\n([^-]+)\\\\r/';
$str = 'b\'----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="username"\\r\\n\\r\\nmyusername\\r\\n----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="password"\\r\\n\\r\\nmypassword\\r\\n----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="keyword"\\r\\n\\r\\nmykeyword\\r\\n----------------------------941135026682458398564529--\\r\\n\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);