use strict;
my $str = 'b\'----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="username"\\r\\n\\r\\nmyusername\\r\\n----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="password"\\r\\n\\r\\nmypassword\\r\\n----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="keyword"\\r\\n\\r\\nmykeyword\\r\\n----------------------------941135026682458398564529--\\r\\n\'';
my $regex = qr/\bname=\"keyword\"\\r\\n\\r\\n([^-]+)\\r/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}