// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\bname=\"keyword\"\\r\\n\\r\\n([^-]+)\\r"#).unwrap();
let string = "b'----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name=\"username\"\\r\\n\\r\\nmyusername\\r\\n----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name=\"password\"\\r\\n\\r\\nmypassword\\r\\n----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name=\"keyword\"\\r\\n\\r\\nmykeyword\\r\\n----------------------------941135026682458398564529--\\r\\n'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}