const regex = new RegExp('\\bname=\\"keyword\\"\\\\r\\\\n\\\\r\\\\n([^-]+)\\\\r', 'g')
const str = `b'----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="username"\\r\\n\\r\\nmyusername\\r\\n----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="password"\\r\\n\\r\\nmypassword\\r\\n----------------------------941135026682458398564529\\r\\nContent-Disposition: form-data; name="keyword"\\r\\n\\r\\nmykeyword\\r\\n----------------------------941135026682458398564529--\\r\\n'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}