const regex = /Title:.*\r?\n(?:(?!.*Database).*\r?\n)+.*\r?\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Title:.*\\r?\\n(?:(?!.*Database).*\\r?\\n)+.*\\r?\\n', 'g')
const str = `[Title: irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[Database: irrelevant information]
[relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text --> for multiple paragraphs]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);