$re = '/Title:.*\r?\n(?:(?!.*Database).*\r?\n)+.*\r?\n/';
$str = '[Title: irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[Database: irrelevant information]
[relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text --> for multiple paragraphs]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;