import re
regex = re.compile(r"Title:.*\r?\n(?:(?!.*Database).*\r?\n)+.*\r?\n")
test_str = ("[Title: irrelevant information]\n\n"
"[irrelevant information]\n\n"
"[irrelevant information]\n\n"
"[irrelevant information]\n\n"
"[irrelevant information]\n\n"
"[irrelevant information]\n\n"
"[irrelevant information]\n\n"
"[irrelevant information]\n\n"
"[irrelevant information]\n\n"
"[Database: irrelevant information]\n\n"
"[relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text --> for multiple paragraphs]")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)