re = /Title:.*\r?\n(?:(?!.*Database).*\r?\n)+.*\r?\n/
str = '[Title: irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[irrelevant information]
[Database: irrelevant information]
[relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text relevant text --> for multiple paragraphs]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result