# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?<!-)([A-Za-z]+)(?:-\1)+(?=\b(?!-)|\B)/\1/gm;t' <<< "wo-wo-wo-wonder -> wonder
hi-hi-hi-hi -> hi
wo-wo-wo -> wo
f-f-f-fight
pre-pre-trained
pre-pre-pretrained
a-a
a-ab
a-b
"