# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?<!-)([A-Za-z]+)(?:-\1)+(?=\b(?!-)|\B)"
test_str = ("wo-wo-wo-wonder -> wonder\n"
"hi-hi-hi-hi -> hi\n"
"wo-wo-wo -> wo\n"
"f-f-f-fight\n"
"pre-pre-trained\n"
"pre-pre-pretrained\n"
"a-a\n"
"a-ab\n"
"a-b\n\n")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.