#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(?<!-)([A-Za-z]+)(?:-\1)+(?=\b(?!-)|\B)"
Local $sString = "wo-wo-wo-wonder -> wonder" & @CRLF & _
"hi-hi-hi-hi -> hi" & @CRLF & _
"wo-wo-wo -> wo" & @CRLF & _
"f-f-f-fight" & @CRLF & _
"pre-pre-trained" & @CRLF & _
"pre-pre-pretrained" & @CRLF & _
"a-a" & @CRLF & _
"a-ab" & @CRLF & _
"a-b" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)