using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!-)([A-Za-z]+)(?:-\1)+(?=\b(?!-)|\B)";
string substitution = @"\1";
string input = @"wo-wo-wo-wonder -> wonder
hi-hi-hi-hi -> hi
wo-wo-wo -> wo
f-f-f-fight
pre-pre-trained
pre-pre-pretrained
a-a
a-ab
a-b
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}