use strict;
my $str = 'wo-wo-wo-wonder -> wonder
hi-hi-hi-hi -> hi
wo-wo-wo -> wo
f-f-f-fight
pre-pre-trained
pre-pre-pretrained
a-a
a-ab
a-b
';
my $regex = qr/\b(?<!-)([A-Za-z]+)(?:-\1)+(?=\b(?!-)|\B)/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";