#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[[a-zA-Z]+(\|((([a-zA-Z]+)|(\:\:)?)*\=\"[\w\s]*(\:\:\w+)*\"))"
Local $sString = "// "/Structure" package" & @CRLF & _
"data-source structurePackage = userPkg/packagedElement[Package|name="Structure"]" & @CRLF & _
" " & @CRLF & _
"synctable-schema ComponentsSchema {" & @CRLF & _
" record dim [Class|mse::metaclassName="SysML::Blocks::Block"]{" & @CRLF & _
" key column /name as PublicId" & @CRLF & _
" column /ownedAttribute[Property|mse::metaclassName="MD Customization for SysML::additional_stereotypes::ValueProperty", name="label"]/defaultValue[LiteralString]/value as Label" & @CRLF & _
" }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")