import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[a-zA-Z]+(\\|((([a-zA-Z]+)|(\\:\\:)?)*\\=\\\"[\\w\\s]*(\\:\\:\\w+)*\\\"))";
final String string = "// \"/Structure\" package\n"
+ "data-source structurePackage = userPkg/packagedElement[Package|name=\"Structure\"]\n"
+ " \n"
+ "synctable-schema ComponentsSchema {\n"
+ " record dim [Class|mse::metaclassName=\"SysML::Blocks::Block\"]{\n"
+ " key column /name as PublicId\n"
+ " column /ownedAttribute[Property|mse::metaclassName=\"MD Customization for SysML::additional_stereotypes::ValueProperty\", name=\"label\"]/defaultValue[LiteralString]/value as Label\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}