package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[a-zA-Z]+(\|((([a-zA-Z]+)|(\:\:)?)*\=\"[\w\s]*(\:\:\w+)*\"))`)
var str = `// "/Structure" package
data-source structurePackage = userPkg/packagedElement[Package|name="Structure"]
synctable-schema ComponentsSchema {
record dim [Class|mse::metaclassName="SysML::Blocks::Block"]{
key column /name as PublicId
column /ownedAttribute[Property|mse::metaclassName="MD Customization for SysML::additional_stereotypes::ValueProperty", name="label"]/defaultValue[LiteralString]/value as Label
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}