using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[a-zA-Z]+(\|((([a-zA-Z]+)|(\:\:)?)*\=\""[\w\s]*(\:\:\w+)*\""))";
string input = @"// ""/Structure"" package
data-source structurePackage = userPkg/packagedElement[Package|name=""Structure""]
synctable-schema ComponentsSchema {
record dim [Class|mse::metaclassName=""SysML::Blocks::Block""]{
key column /name as PublicId
column /ownedAttribute[Property|mse::metaclassName=""MD Customization for SysML::additional_stereotypes::ValueProperty"", name=""label""]/defaultValue[LiteralString]/value as Label
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}