# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(http[s]?)\:\\/\\/([\w\-_]+(\.[\w\-_]+){0,5}(\:\d+)?)((\\/[\w\.\-_]+\\/?)*)\\/?(\?([\w\._\-]+\=[\w\.\-_\s+%]*\&?)*)?(\#[\w_\\/\-]*)?//gi;t' <<< "https://regex101.com/users/
https://regex101.com/users/?query=1
https://regex101.com/users/?query=1"