package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(http[s]?)\:\/\/([\w\-_]+(\.[\w\-_]+){0,5}(\:\d+)?)((\/[\w\.\-_]+\/?)*)\/?(\?([\w\._\-]+\=[\w\.\-_\s+%]*\&?)*)?(\#[\w_\/\-]*)?`)
var str = `https://regex101.com/users/
https://regex101.com/users/?query=1
https://regex101.com/users/?query=1`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}