# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http[s]?)\:\/\/([\w\-_]+(\.[\w\-_]+){0,5}(\:\d+)?)((\/[\w\.\-_]+\/?)*)\/?(\?([\w\._\-]+\=[\w\.\-_\s+%]*\&?)*)?(\#[\w_\/\-]*)?"
test_str = ("https://regex101.com/users/\n"
"https://regex101.com/users/?query=1\n"
"https://regex101.com/users/?query=1")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.