import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http[s]?)\\:\\/\\/([\\w\\-_]+(\\.[\\w\\-_]+){0,5}(\\:\\d+)?)((\\/[\\w\\.\\-_]+\\/?)*)\\/?(\\?([\\w\\._\\-]+\\=[\\w\\.\\-_\\s+%]*\\&?)*)?(\\#[\\w_\\/\\-]*)?";
final String string = "https://regex101.com/users/\n"
+ "https://regex101.com/users/?query=1\n"
+ "https://regex101.com/users/?query=1";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}