#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\S+\s*)\1{2,}"
Local $sString = "singleton duplicate duplicate triplicate triplicate triplicate" & @CRLF & _
"" & @CRLF & _
"(not a space after third triplicate, it is a newline)" & @CRLF & _
"" & @CRLF & _
"singleton duplicate duplicate triplicate triplicate triplicate " & @CRLF & _
"" & @CRLF & _
"(it matches this time because I added a space after third triplicate)" & @CRLF & _
"" & @CRLF & _
"(next does not match because there is no white space at the end of the line)" & @CRLF & _
"" & @CRLF & _
"singleton duplicate duplicate triplicate triplicate triplicate"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")