$re = '/(\S+\s*)\1{2,}/';
$str = 'singleton duplicate duplicate triplicate triplicate triplicate
(not a space after third triplicate, it is a newline)
singleton duplicate duplicate triplicate triplicate triplicate
(it matches this time because I added a space after third triplicate)
(next does not match because there is no white space at the end of the line)
singleton duplicate duplicate triplicate triplicate triplicate';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);