import Foundation
let pattern = #"(\S+\s*)\1{2,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
singleton duplicate duplicate triplicate triplicate triplicate
(not a space after third triplicate, it is a newline)
singleton duplicate duplicate triplicate triplicate triplicate
(it matches this time because I added a space after third triplicate)
(next does not match because there is no white space at the end of the line)
singleton duplicate duplicate triplicate triplicate triplicate
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)