use strict;
my $str = 'singleton duplicate duplicate triplicate triplicate triplicate
(not a space after third triplicate, it is a newline)
singleton duplicate duplicate triplicate triplicate triplicate
(it matches this time because I added a space after third triplicate)
(next does not match because there is no white space at the end of the line)
singleton duplicate duplicate triplicate triplicate triplicate';
my $regex = qr/(\S+\s*)\1{2,}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}