re = /(\S+\s*)\1{2,}/
str = 'singleton duplicate duplicate triplicate triplicate triplicate
(not a space after third triplicate, it is a newline)
singleton duplicate duplicate triplicate triplicate triplicate
(it matches this time because I added a space after third triplicate)
(next does not match because there is no white space at the end of the line)
singleton duplicate duplicate triplicate triplicate triplicate'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end