# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*\b\d+\b\s*//gm;t' <<< "0 I64 EB MM 93
1519 KINGSCROSS RD
28 VA288 298
JOHN RANDOLPH RD
4700 WALMSLEY BL
BOWLING GREEN RD / BOB WHITE RD
BRUCE CT /FLORIDA AV
BUCK RD AND WHITEHALL RD
DOWNTOWN EWRESSWY EB 2ND ST
HYHLAND VISTA / GEORGE WASHINGTON BL
HYHLAND VISTA / GEORGE WASHINGTON BL
HYHLAND VISTA DR / GEORGE WASHINGTON BL
I95 25 43
LAUARL RIDGE MILL RD /CLARENCE RD
LAUARL RIDGE MILL RD /CLARENCE RD
NOVAH HOWARD ST /SEMINARY RD
OLD COUVAHOUSE RD R COUVAHOUSE RD
OLD COUVAHOUSE RD R COUVAHOUSE RD
WOODLAND AND ROANOKE
1501 SAMS CR1
15281 WHITEHEAD RD
1532 MARLBORO ST
16907 BRANDERS BRIDGE RD
1750 WILLIAM ST"