import re
regex = re.compile(r"\s*\b\d+\b\s*", flags=re.MULTILINE)
test_str = ("0 I64 EB MM 93\n"
"1519 KINGSCROSS RD\n"
"28 VA288 298\n"
"JOHN RANDOLPH RD\n"
"4700 WALMSLEY BL\n"
"BOWLING GREEN RD / BOB WHITE RD\n"
"BRUCE CT /FLORIDA AV\n"
"BUCK RD AND WHITEHALL RD\n"
"DOWNTOWN EWRESSWY EB 2ND ST\n"
"HYHLAND VISTA / GEORGE WASHINGTON BL\n"
"HYHLAND VISTA / GEORGE WASHINGTON BL\n"
"HYHLAND VISTA DR / GEORGE WASHINGTON BL\n"
"I95 25 43\n"
"LAUARL RIDGE MILL RD /CLARENCE RD\n"
"LAUARL RIDGE MILL RD /CLARENCE RD\n"
"NOVAH HOWARD ST /SEMINARY RD\n"
"OLD COUVAHOUSE RD R COUVAHOUSE RD\n"
"OLD COUVAHOUSE RD R COUVAHOUSE RD\n"
"WOODLAND AND ROANOKE\n"
"1501 SAMS CR1\n"
"15281 WHITEHEAD RD\n"
"1532 MARLBORO ST\n"
"16907 BRANDERS BRIDGE RD\n"
"1750 WILLIAM ST")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)