#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^A(?:(?![A-Z]{2}).)*?\K\d+"
Local $sString = "A bcd 1 should match and capture 1" & @CRLF & _
"Abcd1 should match and capture 1" & @CRLF & _
"A bcd should not match because there is no number" & @CRLF & _
"A BCd 1 should not match because there is a capital C between the A and the number" & @CRLF & _
"A bcd 1 EF should match because 1 is before the EF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")