re = /^A(?:(?![A-Z]{2}).)*?\K\d+/m
str = 'A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd should not match because there is no number
A BCd 1 should not match because there is a capital C between the A and the number
A bcd 1 EF should match because 1 is before the EF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end