#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^s3://([^/]+)/(.*?([^/]+))(?:\.json)$"
Local $sString = "s3://ssdvs/rhrth/fghfh/gnfhnf/fghrh.json"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")