re = /^s3:\/\/([^\/]+)\/(.*?([^\/]+))(?:\.json)$/
str = 's3://ssdvs/rhrth/fghfh/gnfhnf/fghrh.json'
# Print the match result
str.match(re) do |match|
puts match.to_s
end