using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^s3://([^/]+)/(.*?([^/]+))(?:\.json)$";
string input = @"s3://ssdvs/rhrth/fghfh/gnfhnf/fghrh.json";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}