$re = '`^s3://([^/]+)/(.*?([^/]+))(?:\.json)$`';
$str = 's3://ssdvs/rhrth/fghfh/gnfhnf/fghrh.json';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);