package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\| .* \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(.*\| .* \| CUSTOM \| Receiver video info \|.*)`)
var str = `02.03.2025 07:26:47 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert
02.03.2025 07:26:51 | 00000 | CUSTOM | Receiver video info | "!1IFVNo Video,Unknown,,24bit,,Unknown,,24bit,,,"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}