const regex = /(.*\| .* \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(.*\| .* \| CUSTOM \| Receiver video info \|.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\| .* \\| MESSAGE \\| MQTT Server Device \\| Einstellungen gespeichert)|(.*\\| .* \\| CUSTOM \\| Receiver video info \\|.*)', 'gm')
const str = `02.03.2025 07:26:47 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert
02.03.2025 07:26:51 | 00000 | CUSTOM | Receiver video info | "!1IFVNo Video,Unknown,,24bit,,Unknown,,24bit,,,"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}