import Foundation
let pattern = #"(.*\| .* \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(.*\| .* \| CUSTOM \| Receiver video info \|.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
02.03.2025 07:26:47 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert
02.03.2025 07:26:51 | 00000 | CUSTOM | Receiver video info | "!1IFVNo Video,Unknown,,24bit,,Unknown,,24bit,,,"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)