use strict;
my $str = '02.03.2025 07:26:47 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert
02.03.2025 07:26:51 | 00000 | CUSTOM | Receiver video info | "!1IFVNo Video,Unknown,,24bit,,Unknown,,24bit,,,"
';
my $regex = qr/(.*\| .* \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(.*\| .* \| CUSTOM \| Receiver video info \|.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}